How to convert WMV to MP4

You can use FFmpeg (a free command-line tool for Mac, Linux and Windows) to encode WMV to MP4. Here is an example syntax:

ffmpeg -i input.wmv -c:v libx264 -crf 23 -c:a aac -q:a 100 output.mp4

This will encode the video to H.264 video and AAC audio, using the default quality. To change the quality for the video, use a different CRF value, where lower means better, e.g. 20 or 18. For audio, 100% is the default quality. Increase the value for better quality.

For the AppleTV specifically, this is what Apple says it supports:

H.264 video up to 1080p, 30 frames per second, High or Main Profile level 4.0 or lower, Baseline profile level 3.0 or lower with AAC-LC audio up to 160 kbit/s per channel, 48 kHz, stereo audio in .m4v, .mp4, and .mov file formats

So, you could use the following command to force the 30 Hz frame rate and High profile:

ffmpeg -i input.wmv -c:v libx264 -crf 23 -profile:v high -r 30 -c:a aac -q:a 100 -ar 48000 output.mp4

How to install SSH2 extension for PHP 7.4

If You have an error like: Call to undefined function ssh2_connect() that’s mean that in your PHP not installed ssh2 extension.

Install this extension is very simple, in Ubuntu Linux or other Debian based distribution just use the command:

sudo apt install php7.4-ssh2

This command will install ssh2 extension to Your PHP 7.4. If you use other PHP version, just change number in this command to Your version.

Mikrotik wireless client disconnection at specified signal levels

Allow everything on WLAN1 that has a signal above -87dBm (eg, signal between -86 and+120 dBm) , and allow even that signal to drop below -87 dBm for 30 sec.

The allow is authenticate (associate) and forwarding (connect to other clients).
The allow-signal-out-of-range is needed because devices are in their hands, so the signal fluctuates, but I prefer not to drop them immediately.

To stop the weak signal connections on WLAN1 the next line is needed. For everything with signal between -87 and -120 dBm there is no authentication allowed.

The allow-signal-out-of range is short here (1 sec) because this is used for roaming clients that are sticky to their first AP, but they may come back very soon to this AP, and I prefer not to deny them longer than needed.

/interface wireless access-list
add allow-signal-out-of-range=30s interface=wlan1 signal-range= -86..120 
add allow-signal-out-of-range=1s authentication=no forwarding=no interface=wlan1 signal-range=-120..-87

Create first program “Hello World” on Assembler in Linux

To create program on Assembler in Linux operating system we need compiler for x86 architecture named nasm

sudo apt install nasm

To compile program in file hello.asm use commands:

nasm -felf64 hello.asm
ld hello.o

To start compiled program use command:

./a.out

Nov let’s create our program in file hello.asm using text editor vim

vim hello.asm

Here is the full code of program:

message:
	db	"Hello World!", 10

_start:
	mov	rax, 1
	mov	rdi, 1
	mov	rsi, message
	mov	rdx, 14
	syscall

	mov	rax, 60
	syscall

	section .data

global _start

section .text

In first two lines we create some label which contains some directive db width string “Hello World!“, and last symbol 10line feed. Directive is like variables in high level programming languages.

Directive db can use 1 byte for writing information and can write constants from -128 to 255 and can write symbols and strings.

Next create label _start: and width command mov we write some data in processor address (register):

mov rax, 1 – move 1 in register rax – in this string we call data recording.
mov rdi, 1 – This register response for input and output stream. When we send 1 in register rdi we say processor to work width standard output stream.
mov rsi, message – we write address of our string in register rsi.
mov rdx, 14 – we write count bytes of our string in register rdx.

Next we make system call width command syscall.

mov rax, 60 – we put number 60 in register rax – this is system call for exit.

And again make system call width command syscall.

At the end of program we run command section .data

Width command global _start we run our program from label _start.

Width command section .text we declare text part of our code

Soltek SL-61D Specifications

The specs for SL-61D comes in these configurations with a retail price tag. The configuration Soltek provides comes with a Intel Pentium II/III or Celeron Slot 1 Ultra ATA/33 PCI/ISA/AGP n/a,.

This Soltek Motherboard can take up to 768 MB ram, with a fixed amount of 0 MB (removable) installed PC100 SDRAM DIMMs.

This full-featured mainstream Motherboard enhances the previous generation Soltek models with the chipsets and new levels of customization. Get the best experience on your Soltek SL-61D Motherboard with improved performance, make it easy to create a home network and share all of your favorite items.

The specs of Motherboard shows full configuration information. The SL-61D is designed for users who require maximum performance in a mainstream Motherboard. Even with its form factor design, the SL-61D doesn’t skimp on performance offering the ideal blend of power and efficiency. The SL-61D is sure to leave a lasting impression with its easy to use and slim design. Located on the side of the unit, the modular bay’s innovative latch is designed for easy insertion and removal of the various module options.

The SL-61D Motherboard only supports Intel Pentium II/III or Celeron. The SL-61D features two on-board data caches for transferring information to and from the processor. These caches are known as the L1 and L2 caches. The SL-61D L1 cache is 64 kilobytes in size, while its L2 cache is rated at either one or two megabytes.

When you have a clear idea of which Motherboard best suits your needs, check for its specifications. As the SL-61D is supported by Soltek, check if the Motherboard has full support and warranties by its manufacturer, like SL-61D specs you will have lots of options from the Motherboard manufacturer to choose from, like the Motherboard processor, Motherboard RAM, its graphics capacity, Motherboard display options and specs, and other features that the Motherboard provides.

How fix Error code on Firefox: SSL_ERROR_UNSUPPORTED_VERSION

Error SSL_ERROR_UNSUPPORTED_VERSION pops up because the website uses an outdated encryption methodology which firefox doesn’t really support now. To temporarily access the website do the following:

  1. Type in “about:config” into the firefox browser address bar
  2. You will reach the “Proceed with Caution” page click on “Accept Risk and Continue
  3. On the net page in the “search preference name” section type in “security.tls.version.min
  4. Click on the pencil icon right next to the search result and change the no in the box to “1
  5. Open a new tab and try re-opening the website again.

Once done browsing the website follow the above steps and revert the no in the box from “1” to “3”. This is a very common problem faced while accessing civilian portals in most govt websites since they haven’t modified the encryption technologies at their end.

Install LAMP server on Ubuntu

All the components of the LAMP server are available to install using the default system repository of Ubuntu. Hence, we can configure the environment without adding an extra repository. However, before moving forward, just run the system update command to ensure the system rebuilds the APT package index cache.

sudo apt update

Install Lamp server

We can install LAMP server components one by one on our Ubuntu system. However, it is a time-consuming process, hence to make it short here we are using a single command. That will not only install the LAMP server but also enable and start all the required services.

sudo apt install lamp-server^ php

The above command will select all the required packages to set up Apache, MySQL, and PHP on your system.

Uninstall the LAMP Server

Well, when it comes to uninstalling the LAMP server completely from your Ubuntu system, we can use the given command:

sudo apt autoremove --purge apache2* mysql-server* php*

How to Convert PNG, JPEG to WebP in Linux?

Webp is an open-source image format in Linux which supports lossless and lossy compression for images on the web.

One of the best practices to optimize the website performance is using compressed images.

This article will cover how to use webp image format for creating compressed and quality images for the website.

Installation

The webp package is already available in the official ubuntu repositories. Run the command below to update the Ubuntu repository to the latest index and install webp package.

sudo apt install webp

Converting image to webp format

Using the cwebp tool, an image can be converted into webp format. Run the cwebp command with option -q to define the quality of image and -o to define the output file.

In this example, I have used image file linux.png and linux.jpeg file to convert in webp format. You can choose your image name accordingly.

cwebp -q 60 linux.png -o linux.webp
cwebp -q 60 linux.jpeg -o linux1.webp

Converting webp image to png and jpeg format

In the previous step, we converted jpeg and png images to webp using cwebp utility tool. Now we will use the dwebp tool to convert webp images into png and jpeg format.

Use the dwep command with the option -o to create png and jpeg image format from webp. In the example, image.webp is used for the conversion.

dwep image.webp -o image.png
dwep image.webp -o image.jpeg